Can I still use Ghostery Lite if I’m not on Mojave?

Absolutely. While Ghostery Lite has been specially designed for Mojave, it will work as effectively when installed on any computer with the High Sierra operating system or later (Version 10.13+).

Access Ghostery Support