Is my device compatible with the Ghostery Privacy Browser?

The Ghostery Privacy Browser for Android is compatible for Android Version 4.1 and later.

The Ghostery Privacy Browser for iOS is compatible for iOS Version 9.0 and later.

Access Ghostery Support